Our platform requires you are using the latest version of Chrome, Firefox, or Edge. If you don't know what browser you are using, navigate to this web site: https://www.whatsmybrowser.org/

If you are below version 80 of any of these browsers, please make necessary updates.

Did this answer your question?